This client is too old to work with working copy / Gentoo

4 11 2008

Estes dias ao tentar comitar uns arquivos no SVN recebi essa mensagem ‘this client is too old to work with working copy‘ WTF???? e com a ajuda do meu amigo enciso chegamos ao seguinte diagnóstico.

  1. O repositório SVN foi criado com uma versão velha do svn 1.3 ou 1.4;
  2. Usando uma ferramenta com uma versão nova do svn (tortoise ou o subeclipse já estão na versão 1.5) foi dado um commit, com isso teu work copy ficou com uma versão mais nova do que a tua ferramenta linha de comando consegue manipular.

Como resolver o problema: Atualiza a versão do seu svn linha de comando, como fazer?

Se você estiver usando o gentoo da um emerge subversion.

Anúncios

Ações

Information

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s




%d blogueiros gostam disto: