Instalar Ioncube PHP / Gentoo

3 12 2008

O Problema

Instalar o loader do ioncube no nosso servidor de desenvolvimento local.

A Solução

  1. Acessar o site http://www.ioncube.com/loaders.php e baixar a versão correta para o seu SO;
  2. baixa via wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz
  3. descompactar via tar -xzvf ioncube_loaders_lin_x86-64.tar.gz
  4. mv ioncube /usr/local
  5. edite o php.ini e acrescente a linha
    zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so
  6. Reinicie o seu apache, se seu script não rodar olhe o log do apache
    tail /var/log/apache2/error_log

Erros Encontrados Durante a Instalação

Failed loading /usr/local/ioncube/ioncube_loader_lin_5.0.so:  /usr/local/ioncube/ioncube_loader_lin_5.0.so: wrong ELF class: ELFCLASS32
Isso aconteceu pq eu estava instalando uma versão 32bits e o kernel do meu servidor é 64.


Ações

Information

2 responses

25 07 2009
cilene

Eu tentei instalar , mas nao conseguir, acho que nao entendi direito o tutorial, vc pode me ajudar? ou me indicar alguem que possa me ajudar? eu posso pagar pelos servicos, se nao for muito caro. obrigada

23 05 2013
Rodrigo Spark

Olá, depois de muito procurar por esse tutorial, encontrei ele aqui, show de bola… ótimo tutorial parabéns…

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s




%d blogueiros gostam disto: