XAMPP 1.7.0 Problemas com PDO Select

29 03 2009

O Problema

O XAMPP é um software muito usando por quem está começando a programar em PHP pois ele facilita a instalação do famoso trio (apache, php e mysql). Na versão 1.7.0 porém existe um problema de compilação e isso faz com que o apache trave quando uma consulta SELECT que usam a lib de conexão PDO for executada:

A Solução

  1. Pare o apache e o mysql;
  2. Acesse a pasta xampp\apache\bin;
  3. Apague o arquivo libmysql.dll;
  4. Renomeie o arquivo libmysql_5.0.51a.dll para libmysql.dll
  5. Starte o apache e o myysql.

Conclusão

Particularmente eu não entendo o motivo pelo qual o pessoal do XAMPP não resolveu este problema. Mas em todos os casos a solução é simples.

Achei a solução deste problema neste site

[]’s Anselmo Battisti


Ações

Information

2 responses

21 03 2010
Gilson Lira

Estou com um problema na instalação do joomla, depois de configurado, ao rodar o painel de administração do joomla, ele dá um erro geral de execução, diversas linhas com a referência(Non-static method JLoader::import() should not be called statically in /opt/lampp/htdocs/joomla/libraries/joomla/import.php ), já verifiquei permissões e não tive sucesso na correção, penso que tem a ver com este post, mas uso linux, a pasta do xampp é /opt/lampp/, mas não encontrei a referência ao apache. Poderia me ajudar ?

21 05 2012
jcardoso

Essa dll “libmysql_5.0.51a.dll” eu copio da pasta do php?

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s




%d blogueiros gostam disto: